SentinelOne
Overview
AlphaSOC normalizes SentinelOne telemetry into the Open Cybersecurity Schema Framework (OCSF) format. The fields listed below are available for use in Sigma detection rules. For complete field definitions and semantics, refer to the linked OCSF class schema pages.
SentinelOne: Authentication
OCSF Category: Identity & Access Management
OCSF Class: Authentication
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidactor.user.domainactor.user.nameactor.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uiddst_endpoint.hostnameis_remotelogon_typelogon_type_idmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionsession.uidseverityseverity_idsrc_endpoint.ipstatusstatus_detailstatus_idtimetime_dttype_nametype_uiduser.domainuser.nameuser.typeuser.type_iduser.uid
SentinelOne: Cross Process Activity
OCSF Category: System Activity
OCSF Class: Process Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionprocess.cmd_lineprocess.created_timeprocess.file.company_nameprocess.file.descprocess.file.extprocess.file.hashes[]process.file.hashes[].algorithm_idprocess.file.hashes[].valueprocess.file.internal_nameprocess.file.nameprocess.file.pathprocess.file.product.nameprocess.file.product.versionprocess.file.signature.algorithmprocess.file.signature.algorithm_idprocess.file.signature.stateprocess.file.signature.state_idprocess.file.sizeprocess.integrityprocess.integrity_idprocess.nameprocess.pidprocess.session.uidprocess.user.nameprocess.user.uidrequested_permissionsseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: File System Activity
OCSF Category: System Activity
OCSF Class: File System Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidfile.company_namefile.created_timefile.descfile.extfile.hashes[]file.hashes[].algorithm_idfile.hashes[].valuefile.internal_namefile.modified_timefile.namefile.pathfile.product.namefile.product.versionfile.signature.algorithmfile.signature.algorithm_idfile.signature.statefile.signature.state_idfile.sizemetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: HTTP Activity
OCSF Category: Network Activity
OCSF Class: HTTP Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uiddst_endpoint.iphttp_request.http_methodhttp_request.referrerhttp_request.url.hostnamehttp_request.url.pathhttp_request.url.schemehttp_request.url.url_stringhttp_request.user_agentmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: Kernel Extension Activity
OCSF Category: System Activity
OCSF Class: Kernel Extension Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uiddriver.file.company_namedriver.file.created_timedriver.file.descdriver.file.extdriver.file.hashes[]driver.file.hashes[].algorithm_iddriver.file.hashes[].valuedriver.file.internal_namedriver.file.modified_timedriver.file.namedriver.file.pathdriver.file.product.namedriver.file.product.versiondriver.file.signature.algorithmdriver.file.signature.algorithm_iddriver.file.signature.statedriver.file.signature.state_iddriver.file.sizemetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: Module Activity
OCSF Category: System Activity
OCSF Class: Module Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionmodule.file.company_namemodule.file.created_timemodule.file.descmodule.file.extmodule.file.hashes[]module.file.hashes[].algorithm_idmodule.file.hashes[].valuemodule.file.internal_namemodule.file.modified_timemodule.file.namemodule.file.pathmodule.file.product.namemodule.file.product.versionmodule.file.signature.algorithmmodule.file.signature.algorithm_idmodule.file.signature.statemodule.file.signature.state_idmodule.file.sizeseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: Process Activity
OCSF Category: System Activity
OCSF Class: Process Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionprocess.cmd_lineprocess.created_timeprocess.file.company_nameprocess.file.descprocess.file.extprocess.file.hashes[]process.file.hashes[].algorithm_idprocess.file.hashes[].valueprocess.file.internal_nameprocess.file.nameprocess.file.pathprocess.file.product.nameprocess.file.product.versionprocess.file.signature.algorithmprocess.file.signature.algorithm_idprocess.file.signature.stateprocess.file.signature.state_idprocess.file.sizeprocess.integrityprocess.integrity_idprocess.nameprocess.pidprocess.session.uidprocess.user.nameprocess.user.uidseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: Scheduled Job Activity
OCSF Category: System Activity
OCSF Class: Scheduled Job Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidjob.file.namejob.file.pathjob.namemetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionseverityseverity_idtimetime_dttype_nametype_uid
SentinelOne: Script Activity
OCSF Category: System Activity
OCSF Class: Script Activity
OCSF Fields
activity_idactivity_nameactor.process.cmd_lineactor.process.created_timeactor.process.file.company_nameactor.process.file.descactor.process.file.extactor.process.file.hashes[]actor.process.file.hashes[].algorithm_idactor.process.file.hashes[].valueactor.process.file.internal_nameactor.process.file.nameactor.process.file.pathactor.process.file.product.nameactor.process.file.product.versionactor.process.file.signature.algorithmactor.process.file.signature.algorithm_idactor.process.file.signature.stateactor.process.file.signature.state_idactor.process.file.sizeactor.process.integrityactor.process.integrity_idactor.process.nameactor.process.parent_process.cmd_lineactor.process.parent_process.created_timeactor.process.parent_process.file.company_nameactor.process.parent_process.file.descactor.process.parent_process.file.extactor.process.parent_process.file.hashes[]actor.process.parent_process.file.hashes[].algorithm_idactor.process.parent_process.file.hashes[].valueactor.process.parent_process.file.internal_nameactor.process.parent_process.file.nameactor.process.parent_process.file.pathactor.process.parent_process.file.product.nameactor.process.parent_process.file.product.versionactor.process.parent_process.file.signature.algorithmactor.process.parent_process.file.signature.algorithm_idactor.process.parent_process.file.signature.stateactor.process.parent_process.file.signature.state_idactor.process.parent_process.file.sizeactor.process.parent_process.integrityactor.process.parent_process.integrity_idactor.process.parent_process.nameactor.process.parent_process.pidactor.process.parent_process.session.uidactor.process.parent_process.user.nameactor.process.parent_process.user.uidactor.process.pidactor.process.session.uidactor.process.user.nameactor.process.user.uidcategory_namecategory_uidclass_nameclass_uidcountdevice.hostnamedevice.ipdevice.macdevice.os.namedevice.os.typedevice.os.type_iddevice.uidmetadata.event_codemetadata.product.namemetadata.product.vendor_namemetadata.product.versionmetadata.profiles[]metadata.tenant_uidmetadata.uidmetadata.versionscript.hashes[]script.hashes[].algorithm_idscript.hashes[].valuescript.script_content.is_truncatedscript.script_content.untruncated_sizescript.script_content.valuescript.typescript.type_idseverityseverity_idtimetime_dttype_nametype_uid